Linux package managersΒΆ

On Debian GNU/Linux version >= 11, Ubuntu version >= 21.04, and Arch Linux there are three packages to install

  • sagemath (for the binaries)

  • sagemath-jupyter (for the browser interface)

  • and the documentation which is called sagemath-doc-en on Debian/Ubuntu and sagemath-doc on Arch Linux.

See repology.org: sagemath for information about SageMath packages in other distributions, and their available versions. Do not install a version of Sage older than 9.2. If you are on an older version of your distribution and a recent version of SageMath is only available on a newer version of the distribution, consider upgrading your distribution.

Gentoo users might want to give a try to sage-on-gentoo.

The Trac wiki page Distribution collects information regarding packaging and distribution of SageMath.